Remote Desktop License Server, Credentials Required

17
2014-04
  • Doug Porter

    I have had a machine, call it Server-1, running Windows Server 2008-R2 for a couple years. We have it mainly to run XenApp. It runs all of its own License Servers (so, for XenApp and windows remote desktop licenses).

    I'm now trying to add a second machine, call it Server-2. I want it to use Server-1 for its Remote Desktop License Server.

    That works beautifully and Server-2 is up and running fine. Except now Server-1's now failing to get its Remote Desktop licenses (from itself).

    I run Remote Desktop Session Host Configuration and go to, "Licensing Diagnosis", and it tells me that "Administrator credentials for license server Server-1 are required." This as I'm logged in as Administrator on that machine already.

    It tells me that Connectivity is Available, but that Credentials are Not Available.

    I've tried the, "Provide Credentials", link, but it fails. I've confirmed that the credentials for Server-1 Administrator are correct.

    If I run the Session Host Configuration on Server-2 then it all looks perfect.

    If I try, "Provide Credentials", on Server-2, which is using Server-1 as its license server, and use the exact same credentials, it works.

    The 2 servers are not in a domain, just in the generic Workgroup, "WORKGROUP".

    Obviously I'm missing something fundamental, here, but it's driving me crazy. If anyone can give me any suggestions I'd really appreciate it!


    [Edit]

    I have it working. I don't know specifically WHY this fixes, but I include an answer here in case anyone else runs into similar problems.

    These are Amazon EC2 servers (should've been mentioned up top, probably). In the past, I had specified the server name as a simple host name, not a FQDN. When I went to add Server-2, I changed so I specified the FQDN for the license server on each machine.

    My fix was to change Server-1's license server to be Server-1, rather than Server-1.whatever.com

    On Server-2, it is still listed as Server-1.whatever.com

    I don't understand (at all) why that was a problem. That is, I could imagine us not having the right port open, except that it works from Server-2.

    Further, it told me it had Connectivity! ("Available" under the Connectivity column in Remote Desktop Services License Server Information).

    Still, after spending 2 days on this, to fix it 23 minutes after posting my question is pretty interesting. All credit to serverfault.com...

  • Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

    Related Question

    How do I remove the on screen keyboard from the logon screen in Windows Remote Desktop Server 2008 R2?
  • Gomibushi

    The on screen keyboard (OSK) from the "ease of access" tools pops up on EVERY connect to the server, even if you have not activated it.

    I can't seem to find a control panel or reg setting to switch it off.

    It is VERY "in your face" for linux users who connect at lower resolutions and do not provide all credentials, but have to type username and password.

    I'm running a 2008 R2 Terminal Server/Remote Desktop Server.


  • Related Answers
  • user167273

    Go to:

    Start > Control Panel > Ease of Access Center > Use the computer without a mouse or keyboard > Uncheck 'Use On-Screen Keyboard'

  • flemming

    If about do not seem to work try this :

    click "change administrativ settings" to the left on the "Ease of Access Center"

    Check “Apply all settings to the logon desktop” -->Apply

    This work for me !