linux - MySQL 5.6 Upgrade - Incorrect definition of table mysql.proc

23
2014-07
  • Max M.

    After upgrading MySQL to version 5.6.10 from version 5.5 I'm getting the following errors when starting MySQL server:

    2013-03-19 05:32:38 2666 [Note] /usr/sbin/mysqld: ready for connections. Version: '5.6.10'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  MySQL Community Server (GPL)
    2013-03-19 05:43:27 2666 [ERROR] Incorrect definition of table mysql.proc: expected column 'comment' at position 15 to have type text, found type char(64).
    

    I checked out the mysql.proc table and the comment field is set to TEXT. I ran mysql_upgrade after the upgrade. I tried running it again with --force after seeing that error, but that didn't fix it.

  • Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

    Related Question

    windows 7 - "Error 1067: The process terminated unexpectedly" when trying to install MySQL on Win7 x64
  • Contango

    I've run into a brick wall trying to install MySQL v5.5 on my machine.

    My PC is Windows 7 x64, Enterprise edition.

    MySQL installs fine, but when I run the "MySQL Instance Configuration Wizard", it pauses forever on the step "Start Service" (I can let it run for 30 minutes with no response). If I go into services, I see that the "MySQL" service hasn't started, and if I try to start it, it says "Windows could not start MySQL Service on Local Computer. Error 1067: The process terminated unexpectedly."

    I've tried the following:

    • Turning off firewall.
    • Uninstalling all antivirus software.
    • Installing / reinstalling 32-bit version of MySQL.
    • Installing / reinstalling 64-bit version of MySQL.
    • Uninstalling, deleting the contents of "C:\program files\MySQL" and "C:\program files (x86)\MySQL", reinstalling.
    • Checking to see that there is no rogue services named MySQL???? (from a previous install).
    • Checking that port 3306 is not used by an alternate program.
    • Changing the default port that MySQL uses.
    • Checking for "my.ini" and "my.ini.cnf" in "C:\windows" (nothing there but that can cause a problem).
    • Running both MySQL installer, and configuration wizard, in "Adminstrator mode".
    • Turning off UAC.
    • Installing with defaults, not changing anything.
    • Rebooting my machine (about 6 reboots so far).
    • Opening up port 3306 in the firewall (both TCP and UDP, inbound and outbound).
    • Swearing at the klutz of a programmer who designed MySQL so you can't even install it (as if that would help!)

    My machine is working 100% in every other way. InfiniDB (a MySQL compatible database) installs 100%, as does Visual Studio 2010, Microsoft SQL Server, etc, etc.

    Your advice on how to work around this?

    p.s. Here is the screen it got stuck on for 15 minutes until I killed the process:

    alt text

    Update 2010-12-20

    Tried MySQL v5.1, it didn't work either. Its amazing - if you type "mysqld /?", or "mysqld -help", it doesn't give you any help. And, if you try to restart the service manually, it doesn't display any error messages. Could it be any more unhelpful?

    Update 2010-12-21

    Installed MySQL 6.0 alpha, and it worked. However, I'd rather not use an alpha release, given that the "stable" release is anything but :(

    Update 2010-12-21

    Found http://dev.mysql.com/doc/refman/5.1/en/windows-troubleshooting.html, dealing with troubleshooting under Windows.

    Discovered that you can generate an error log if the service doesn't start - see here: http://dev.mysql.com/doc/refman/5.1/en/error-log.html

    Update 2010-12-21

    Aha! A clue. To actually see the error, add "--console":

    mysqld --console
    

    This returns:

    101221 13:57:28 [Note] Plugin 'FEDERATED' is disabled.
    InnoDB: The InnoDB memory heap is disabled
    InnoDB: Mutexes and rw_locks use Windows interlocked functions
    InnoDB: Compressed tables use zlib 1.2.3
    101221 13:57:28  InnoDB: Initializing buffer pool, size = 203.0M
    101221 13:57:28  InnoDB: Completed initialization of buffer pool
    InnoDB: Error: log file .\ib_logfile0 is of different size 0 56623104 bytes
    InnoDB: than specified in the .cnf file 0 106954752 bytes!
    101221 13:57:28 [ERROR] Plugin 'InnoDB' init function returned error.
    101221 13:57:28 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
    101221 13:57:28 [ERROR] Unknown/unsupported storage engine: INNODB
    101221 13:57:28 [ERROR] Aborting
    101221 13:57:28 [Note] mysqld: Shutdown complete
    

    Update 2010-12-21

    It now installs properly. See the answer below.


  • Related Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.