Installation of Oracle 11g on remote server(Ubuntu) connected using ssh

23
2014-04
  • Questioner

    When I tried running installer of oracle using oracle user after remotely connected(using ssh), I am getting this error.

    [oracle@htrtret database]$ ./runInstaller
    Starting Oracle Universal Installer...
    
    Checking Temp space: must be greater than 120 MB.  Actual 1195 MB    Passed
    Checking swap space: must be greater than 150 MB.  Actual 4094 MB    Passed
    Checking monitor: must be configured to display at least 256 colors
        >>> Could not execute auto check for display colors using command /usr/bin/xdpyinfo. Check if the DISPLAY variable is set.    Failed <<<<
    
    Some requirement checks failed. You must fulfill these requirements before
    continuing with the installation,at which time they will be rechecked.
    
    Continue? (y/n) [n] y
    
    Rechecking installer requirements....
    Preparing to launch Oracle Universal Installer from /tmp/OraInstall2010-10-26_07-29-52AM. Please wait ...Error in CreateOUIProcess(): 13
    : Permission denied 
    
  • Answers
  • sideh

    You might be able to do it with X forwarding:

    ssh -X <hostname> 
    

    You'll need to be running an X server on the machine you're connecting from and ensure that "X11Forwarding yes" is set in sshd_config on the server.

  • Gaius

    Just installing the binaries, right? If you have an existing installation

    1. Tar and gzip the ORACLE_HOME and scp it across
    2. Unpack it in the location that you want the new ORACLE_HOME
    3. cd $ORACLE_HOME/clone/bin
    4. perl clone.pl ORACLE_HOME=/my/oracle/home ORACLE_BASE=/my/oracle/base ORACLE_HOME_NAME=MyOraHome

    This is a headless technique for mass deployments.

    Make sure you have all the prereqs. The base way to do this is add the Oracle Yum server and yum install oracle-validated.

  • Mircea Vutcovici

    The issue was with writing some data from oracle on a non-writable directory(default tmp).So changed it using export TMP=$HOME/tmp.

    I tried enabling X11 forwarding to run the oracle installer.Now I am getting this error:

    Xlib: connect ion to "localhost:10.0" refused by server Xlib: PuTTY X11 proxy: wrong authentication protocol attempted Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using 'localhost:10.0' as the value of the DISPLAY variable. at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method) at sun.awt.X11GraphicsEnvironment.access$000(X11GraphicsEnvironment.java :53) at sun.awt.X11GraphicsEnvironment$1.run(X11GraphicsEnvironment.java:142) at java.security.AccessController.doPrivileged(Native Method) at sun.awt.X11GraphicsEnvironment.(X11GraphicsEnvironment.java:1 31) at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Class.java:164) at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvi ronment.java:68) at java.awt.Window.init(Window.java:270) at java.awt.Window.(Window.java:318) at java.awt.Frame.(Frame.java:419) at oracle.ewt.popup.PopupFrame.(Unknown Source) at oracle.ewt.lwAWT.BufferedFrame.(Unknown Source) at oracle.sysman.oio.oioc.OiocOneClickInstaller.(OiocOneClickInsta ller.java:328) at oracle.sysman.oio.oioc.OiocOneClickInstaller.(OiocOneClickIns taller.java:168)


  • Related Question

    linux - Installing Oracle 11g for 64bit on Ubuntu 10.04 server 64bit?
  • Charly

    I want to install Oracle 11g for 64bit on a Ubuntu 10.04 64bit server.Does anybody knows how to install the Oracle 11g on Ubuntu from the scratch(pre-installation to post-installation)?


  • Related Answers
  • arclight

    Is this for development or personal use or for production? I'd review the release notes for Oracle to see if Ubuntu is supported, but further, I'd ask yourself why you want Oracle on Ubuntu. Nothing against Ubuntu but Oracle is a finicky beast an it is best not to stray too far from the supported platforms especially if this is a production setup. You may be better off biting the bullet and installing on RHEL or CentOS (not Fedora Core) because RHEL is supported and CentOS is known to work, being derived from RHEL sources. Again, while Ubuntu LTS may work nicely for 90% of your infrastructure, Oracle is very demanding - deviate from supported configurations at your peril.

    Oracle's dependency checks are not for show. People run Oracle for two reasons - either they need the reliability and features of Oracle, or they're running it because someone else told them to (vendor, administrator, client, etc.) If you don't need it, don't use it because it's a severe pain for a neophyte to manage. If you do need it, you obviously have deep pockets - don't waste your time trying to get Oracle running on a desktop OS. Pay for RHEL or if you know what you're doing or don't care, use CentOS because it's as close a production OS for Oracle as you'll get without buying RHEL. I like Ubuntu too, but it's the wrong platform in this case.

  • Ofir Manor

    I have both Oracle 10g release 2 and 11g running on my laptop Ubuntu 8.04 64-bit. I have following the phytian guide... What is the exact error you get during install?

    BTW - some have suggested you install in a supported environment. If you want - create a new VM and install Oracle EL - a clone of RHEL, fully supported, fully free. I would just get the EL 5.3 from here.

    BTW - if you use VirtualBox - the version in the Ubuntu 8.04 repository used to be old and didn't support 64-bit guests, so if you use VirtualBox and not VmWare, get the latest release from their site

    ----- EDIT -----

    OK, I found my notes of the steps I took. I believe it is quite accurate.

    Oracle Documentation talks about user "oracle" with groups "dba","oinstall". Since this is just a laptop, I used the default user/group (in my case, ofir/ofir), so change it to your user.

    PRE-INSTALL

    as root run:

    ln -s /usr/bin/basename /bin/basename

    ln -s /usr/bin/awk /bin/awk

    ln -s /usr/bin/rpm /bin/rpm

    mkdir /etc/rc.d

    ln -s /etc/rc0.d /etc/rc.d/rc0.d

    ln -s /etc/rc2.d /etc/rc.d/rc2.d

    ln -s /etc/rc3.d /etc/rc.d/rc3.d

    ln -s /etc/rc4.d /etc/rc.d/rc4.d

    ln -s /etc/rc5.d /etc/rc.d/rc5.d

    ln -s /etc/rc6.d /etc/rc.d/rc6.d

    ln -s /etc/init.d /etc/rc.d/init.d

    add to /etc/sysctl.conf :

    fs.file-max = 65535

    kernel.shmall = 2097152

    kernel.shmmax = 2147483648

    kernel.shmmni = 4096

    kernel.sem = 250 32000 100 128

    net.ipv4.ip_local_port_range = 1024 65000

    net.core.rmem_default = 1048576

    net.core.rmem_max = 1048576

    net.core.wmem_default = 262144

    net.core.wmem_max = 262144

    add to /etc/security/limits.conf (replace ofir with your username):

    ofir soft nproc 2047

    ofir hard nproc 16383

    ofir soft nofile 1023

    ofir hard nofile 65535

    Add to /etc/pam.d/login :

    session required /lib/security/pam_limits.so

    session required pam_limits.so

    sudo apt-get install gcc make rpm libmotif3 libstdc++5 gawk alien ksh gcc-3.3 g++-3.3 libstdc++5 libc6 libc6-dev gcc make binutils lesstif2 ++-multilib

    INSTALLING

    (I assume you have done it before, if not - just follow the GUI and cosult the docs):

    run the 11.1.0.6 installer, choose software only install. Ignore a few minor link errors (there were no link errors after 11.1.0.7 patch)

    If needed, install the 11.1.0.6 examples disk as well

    Install the 11.1.0.7 (available from metalink)

    run netca to create a new listener (accept all the defaults)

    run dbca to create a new database (even the database console works great for me)

  • Andor

    As a note... last time I installed Oracle, it depended on some binary packages that were 32bit, so I had to install the ia32-libs package ( aptitude install ia32-libs ) , for it to work...

    Do you have any concrete problem?

  • ConcernedOfTunbridgeWells

    Maybe you can take look here: www.pythian.com/news/968/installing-oracle-11g-on-ubuntu-804-lts-hardy-heron or www.pythian.com/news/1355/installing-oracle-11gr1-on-ubuntu-810-intrepid-ibex

  • m0j0

    I spent about a week last fall pulling my hair out trying to get Oracle 10g installed on Ubuntu. I finally gave up and switched to RedHat and had it up and running in one day.

  • wazoox

    I installed Oracle 10 on Debian, and it sometimes failed on "make"'ing some files. Basically, I simply had to read the log, do the "make" by hand with the needed changes (usually some mangled path) then click "ignore" in the installer. Hope this helps.

  • Area 51

    I like the response given by arclight answered Jun 1 '09 at 6:48

    I have been trying to get oracle to work on various linux distros not supported but all have issues. I will try RHEL or Centos for optimum performance.