switch - Cisco 3750 - weird tcam usage

25
2014-04
  • pauska

    I have two 3750-X switches operating in a stack. The SDM template is set to desktop routing, as we need a lot of next-hop unicast routes.

    The tcam usage is not looking quite right...every value is maxed out. Has anyone seen this before (or have any explanation to it), or should I open a TAC case right away?

    CAM Utilization for ASIC# 0                      Max            Used
                                                 Masks/Values    Masks/values
    
    Unicast mac addresses:                       3292/3292        627/627
    IPv4 IGMP groups + multicast routes:         1120/1120          1/1
    IPv4 unicast directly-connected routes:      3072/3072         92/92
    IPv4 unicast indirectly-connected routes:    8144/8144       3730/3730
    IPv4 policy based routing aces:               498/498          13/13
    IPv4 qos aces:                                474/474          21/21
    IPv4 security aces:                           972/972          33/33
    

    Edit:

    Here is an example from Cisco, wich looks quite different: http://www.cisco.com/en/US/products/hw/switches/ps5023/products_tech_note09186a00807213f5.shtml#SDM

    Edit2:

    I might want to add the reason why I'm investigating this: We're experiencing very random latency when we ping this switch, no matter what VRF or VLAN we use. The CPU utilization looks a bit weird as well:

        6644646454444584445446554355447464554555554444464645444445457455556545
        6907344850716408995114547934140092790235780624077383760641040825126164
    100
     90
     80               *
     70 **            *               * *              *            *     *
     60 **  * * *     *   *  **       * * **   ***     * *          *  *  *
     50 ** ** *** * *******  **** **  * * ** ***** *   ******* * * ***********
     40 **********************************************************************
     30 **********************************************************************
     20 ######################################################################
     10 ######################################################################
       0....5....1....1....2....2....3....3....4....4....5....5....6....6....7.
                 0    5    0    5    0    5    0    5    0    5    0    5    0
                       CPU% per hour (last 72 hours)
    

    Current usage:

    CPU utilization for five seconds: 25%/1%; one minute: 24%; five minutes: 24%
     PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
      81   105562156    425102     248330 13.41% 11.52% 11.62%   0 Adjust Regions
      75    38660112   6968319       5547  3.03%  2.94%  2.84%   0 RedEarth Tx Mana
      74    24316130  11091855       2192  1.59%  1.59%  1.59%   0 RedEarth I2C dri
       4    15330586    677415      22631  0.00%  1.14%  1.14%   0 Check heaps
    
  • Answers
  • Hyppy

    You're not maxed out. The second set of numbers is the current utilization, and the first column is the max.

    Edit 1: On page 17 of this link is a decent explanation of it.

    Edit 2: For your underlying issue that you are noting, take a look at show controller utilization to get a good feel for the traffic you're seeing. Also, here's a decent guide from Cisco on troubleshooting high CPU usage in 3750s (linked here)


  • Related Question

    switch - How to Change a VLAN Assignement for an Interface on a Cisco 3750
  • mac

    I'm having some trouble trying to figure out how to Change a VLAN Assignement for an Interface on a Cisco 3750.

    I want to change:

    !
    interface GigabitEthernet1/0/3
    switchport access vlan 2
    switchport mode access
    spanning-tree portfast
    !
    

    Into:

    !
    interface GigabitEthernet1/0/3
     switchport access vlan 3
     switchport mode access
     spanning-tree portfast
    !
    

    However I haven't been able to do it successfully.

    Any suggestions?

    Thanks!


  • Related Answers
  • sparks
    conf t
    int g1/0/3
    switchport access vlan 3
    do wr mem
    
  • Chad Huneycutt

    What have you tried? It should go something like this:

    switch# config t
    switch(config)#  int gi1/0/3
    switch(config-if)#switchport access vlan 3
    

    Then ctrl-z and write mem